aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJuan J. Martinez <jjm@usebox.net>2019-07-27 10:56:50 +0100
committerJuan J. Martinez <jjm@usebox.net>2019-07-27 10:56:50 +0100
commit6d4939328b575d9359e26f3aff85242133d03e9c (patch)
tree085b355863aeb9bc29686d0d0486caf59d063706 /setup.py
parent5797d6d4aaf6bd6155a4312f3d7ca4ad251b190a (diff)
downloadz80count-6d4939328b575d9359e26f3aff85242133d03e9c.tar.gz
z80count-6d4939328b575d9359e26f3aff85242133d03e9c.zip
Added long description
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py10
1 files changed, 9 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 8e0cf64..ed3ec62 100644
--- a/setup.py
+++ b/setup.py
@@ -3,11 +3,19 @@ from setuptools import setup
version = "0.5.0"
+
+def readme():
+ try:
+ return open('README.md').read()
+ except:
+ return ""
+
setup(
name="z80count",
version=version,
description="A tool to annotate Z80 assembler with cycle counts.",
- long_description="",
+ long_description=readme(),
+ long_description_content_type="text/markdown",
# Get strings from http://pypi.python.org/pypi?%3Aaction=list_classifiers
classifiers=[
"Environment :: Console",