aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJuan J. Martínez <jjm@usebox.net>2019-07-27 10:52:58 +0100
committerGitHub <noreply@github.com>2019-07-27 10:52:58 +0100
commit5797d6d4aaf6bd6155a4312f3d7ca4ad251b190a (patch)
tree91abced97331d5d40088419f424952f99f6457ed /setup.py
parent12b94cec43b00be6c48c865602c642927ad55f86 (diff)
parent2cfc3a0828e76af363c7185403076c3782e52ed5 (diff)
downloadz80count-5797d6d4aaf6bd6155a4312f3d7ca4ad251b190a.tar.gz
z80count-5797d6d4aaf6bd6155a4312f3d7ca4ad251b190a.zip
Merge pull request #4 from patxoca/master
Package z80count as a python distribution
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py40
1 files changed, 40 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..8e0cf64
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,40 @@
+from setuptools import find_packages
+from setuptools import setup
+
+version = "0.5.0"
+
+setup(
+ name="z80count",
+ version=version,
+ description="A tool to annotate Z80 assembler with cycle counts.",
+ long_description="",
+ # Get strings from http://pypi.python.org/pypi?%3Aaction=list_classifiers
+ classifiers=[
+ "Environment :: Console",
+ "Intended Audience :: Developers",
+ "License :: OSI Approved :: MIT License",
+ "Programming Language :: Python :: 3 :: Only",
+ "Topic :: Software Development",
+ ],
+ keywords="",
+ author="Juan J. Martinez",
+ author_email="jjm@usebox.net",
+ url="https://github.com/reidrac/z80count",
+ license="MIT",
+ packages=find_packages(),
+ include_package_data=True,
+ zip_safe=False,
+ install_requires=[
+ ],
+ extras_require={
+ "dev": [
+ "pytest",
+ "tox",
+ ]
+ },
+ entry_points={
+ "console_scripts": [
+ "z80count = z80count.z80count:main",
+ ]
+ },
+)