aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorAlexis Roda <alexis.roda.villalonga@gmail.com>2019-07-27 10:09:52 +0200
committerAlexis Roda <alexis.roda.villalonga@gmail.com>2019-07-27 10:09:52 +0200
commit5f7d94e32812cb02ecde0a9f4fa965002f551c86 (patch)
treeeeffe933a08e3084db2ff0d407e510cf58596d66 /setup.py
parent3556d259a249135c326fc518100b00829f8f8815 (diff)
downloadz80count-5f7d94e32812cb02ecde0a9f4fa965002f551c86.tar.gz
z80count-5f7d94e32812cb02ecde0a9f4fa965002f551c86.zip
Make a python package.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py40
1 files changed, 40 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..8e0cf64
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,40 @@
+from setuptools import find_packages
+from setuptools import setup
+
+version = "0.5.0"
+
+setup(
+ name="z80count",
+ version=version,
+ description="A tool to annotate Z80 assembler with cycle counts.",
+ long_description="",
+ # Get strings from http://pypi.python.org/pypi?%3Aaction=list_classifiers
+ classifiers=[
+ "Environment :: Console",
+ "Intended Audience :: Developers",
+ "License :: OSI Approved :: MIT License",
+ "Programming Language :: Python :: 3 :: Only",
+ "Topic :: Software Development",
+ ],
+ keywords="",
+ author="Juan J. Martinez",
+ author_email="jjm@usebox.net",
+ url="https://github.com/reidrac/z80count",
+ license="MIT",
+ packages=find_packages(),
+ include_package_data=True,
+ zip_safe=False,
+ install_requires=[
+ ],
+ extras_require={
+ "dev": [
+ "pytest",
+ "tox",
+ ]
+ },
+ entry_points={
+ "console_scripts": [
+ "z80count = z80count.z80count:main",
+ ]
+ },
+)